Reviviendo un router TL-WR841ND con OpenWrt

El escenario

Hace unos meses adquirí un router TL-WR841ND con el propósito de usarlo como repetidor Wi-Fi y así extender la señal de la red inalámbrica de una casa. El firmware oficial no permite configurarlo de esa manera, pero, afortunadamente, existen firmwares alternativos que explotan la potencia de muchos routers; uno de ellos es OpenWrt.

Router TL-WR841ND
Router TL-WR841ND

Tras realizar una operación exitosa (y bastante sencilla, como suele ser habitual) de cambio de firmware, empecé a trastear para configurarlo como repetidor. Sin embargo, algo fue mal, y, tras un reinicio, el router se negaba a responder: no podía acceder a él vía web, ni por telnet ni SSH; no se había configurado ninguna dirección de red. Me encontraba ante un ladrillo disfrazado de router.

Las primeras búsquedas me llevaron a donde más me temía: abrir router, buscar conexiones, fabricar un cable serie, soldar… Para alguien que tiene tanta idea de electrónica como McDonald’s de cocina, esto le pareció un reto insuperable. Pero me armé de valor y comencé a destripar el router… ¡Peeero! Tras bucear entre tutoriales, descubro que el firmware OpenWrt ¡cuenta con un modo a prueba de fallos! Así que, con el router desnudo y en coma, decidí abortar la cirujía y probar esta medicina. ¿Resultado? Maravilloso :-D

Ingredientes

Para llevar a cabo la maniobra de resucitación nos hará falta:

  • Un ordenador con conexión RJ-45 (es la típica para la conexión de red por cable).
  • Un cable de red con conectores RJ-45.
  • Nervios de acero (bueno, tampoco hay que exagerar).
  • El muerto (también conocido como router TL-WR841ND).

OpenWrt: modo a prueba de fallos

El modo a prueba de fallos de OpenWrt arranca con los servicios mínimos y una interfaz de red: justo lo que necesitamos para recuperar nuestro router.

Estos son los pasos que tenemos que dar para activar el modo a prueba de fallos:

  1. Desenchufar el router de la corriente.
  2. Enchufar el router a la corriente y encenderlo.
  3. Cuando la luz con la rueda dentada empiece a parpadear, mantenemos pulsado el botón WPS/RESET durante unos segundos hasta que comience a parpadear más rápido.
Detalle de luces del router WR841ND
Detalle de las luces del router
Botón de reinicio del router WR841ND
Botón de reinicio en el router TL-WR841ND (v8)

Bien, ya está activado el modo a prueba de fallos. Ahora nos queda conectarnos al router y finalizar la operación.

Operando en modo a prueba de fallos

Lo que haremos a continuación será dejar el firmware limpito, borrando todas las configuraciones que hayamos hecho y dejándolo como si de una instalación nueva se tratase.

Configuración de red

El router ahora mismo tiene la siguiente IP: 192.168.1.1 Para poder conectarnos a él, hay que configurar otro equipo para que esté dentro de esa subred, es decir, tenemos que ponerle una IP del estilo 192.168.1.X, donde la X puede ser cualquier número entre 2 (el 1 ya está cogido y el 0 es de la dirección de red) y 254.

Por ejemplo, en nuestro equipo configuramos:

  • Dirección IP: 192.168.1.2
  • Dirección de máscara de red: 255.255.255.0

Enchufamos router y ordenador entre sí a través de un cable de red. Importante: si la versión del router es la 8 o superior (el mío es la 8.2), el puerto que usaremos es el que está etiquetado como WAN (de color azul). No vale en otro puerto. Lo sé; lo he probado…

Conexión con el router

Vamos a establecer una conexión entre los dos equipos a través de telnet:

$ telnet 192.168.1.1

Si hay respuesta, veremos una sesión como ésta:

Trying 192.168.1.1...
Connected to 192.168.1.1.
Escape character is '^]'.

 === IMPORTANT ============================
  Use 'passwd' to set your login password
  this will disable telnet and enable SSH
 ------------------------------------------


BusyBox v1.19.4 (2013-03-14 11:28:31 UTC) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 ATTITUDE ADJUSTMENT (12.09, r36088)
 -----------------------------------------------------
  * 1/4 oz Vodka      Pour all ingredients into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
 -----------------------------------------------------
root@(none):/#

Ya estamos dentro del router ;-) Ahora resta ejecutar los siguientes comandos en orden:

# mount_root

Permite montar el último sistema de archivos usado para poder hacer cambios en él y tratar de repararlo.

# passwd

Establecemos la contraseña que queramos para conectarnos posteriormente a través de SSH (y se desactivará el acceso mediante telnet).

# firstboot

De esta manera borraremos la partición donde se instalan los paquetes (JFFS2) y se reiniciarán todas las configuraciones; es como dejar el OpenWrt con los «ajustes de fábrica».

Finalmente reiniciamos:

# reboot -f

Cuando esté de nuevo funcionando el router, abrimos el navegador web y ponemos la IP del router en la barra de direcciones y …

Panel de administración web de OpenWrt

¡Eureka! Ya lo tenemos vivito y coleando :-D

Personalmente me gustaría dar las gracias a todo el equipo de OpenWrt, tanto por quitar los límites de fábrica de muchos dispositivos, como por las horas de entretenimiento que nos dan :-P

77 thoughts on “Reviviendo un router TL-WR841ND con OpenWrt

  1. Hola, me alegro que hayas podido reestablecer el router.

    yo me lo acabo de comprar, tambien la version 8.2, que tal te funciona ahora.

    que firmware openwrt le pusiste, es que quisiera cambiarselo, y aún no tengo claro cual hay que ponerle.

    saludos.

    • ¡Hola, pere!

      Lo bueno del firmware OpenWrt (y cualquier otro que no sea el de fábrica) es que el router de pronto es capaz de hacer muchas más cosas ;-)

      La versión que me descargué para nuestro modelo de router es ésta (como indica en la web oficial).

      En esa web vienen también las instrucciones para instalar ese firmware, pero si tienes cualquier duda, aquí estamos ;-)

      • jeje ;) algun openwrt he provado, siempre livianamente, pero le tenia miedo a este, que no estuviera soportado, probaré estos dias, y te comento ;) como me ha ido. lo quiero como repetidor y estabilidad / permormance responde con la tecnonolia N.

        gracias por la info.

        saludos

        • pere, cualquier aportación es bien recibida. Precisamente lo que quieres intentar es lo mismo que yo. Aún no he tenido tiempo de hacer pruebas, pero tan pronto logre configurarlo como repetidor, publicaré los pasos a seguir.

      • Ola jm sabes mi romper estaba funcionando pero lo deje de usar hace unos meses y oy lo quise ocupar prende la luz de poder fija y la de WiFi no prende y la demás se prenden y se apagan todas juntas y no entiendo esa parte de dos equipos también escribo la ip y me arroja fayo

  2. hola Quisiera saber como puedo resucitar el router tp-link tl-wr841nd V8 por el cual no reconoce la ip por una falla de firmware de dd-wrt y solo enciende la luz de power al reiniciarlo enciende la luz donde esta en candado lo cual creo que esta bloqueado, eh buscado todo para repararlo pero no encuentro nada aun quisiera una ayuda de como recuperar mi router gracias

    • Hola, julio. ¿Has probado lo que se comenta en el artículo sobre activar el modo a prueba de fallos del router?

  3. muchas gracias son unos genios., restablesi el routes despues de 2 noche de no poder dormir., gracias de nuevo

    • Qué buena noticia, rene :D

      Gracias a ti por comentar tus resultados.

      Por fin podrás descansar tranquilo, jejeje.

  4. tengo el mismo fallo que julio rossano agradezco el apoyo he probado la receta anterior y no funciona en mi equipo de igual caracteristica ya que solo prende en boton de power

  5. Hola, Rafael,

    Sólo para saber en qué punto te encuentras: ¿habías instalado el firmware OpenWrt en tu router?

  6. hago todo bien solo que no entra en modo telnet me dice error de host 23 o algo haci ,,, por que me da este error

    • Hola, ivan,

      ¿Has configurado correctamente los dos equipos (router y PC/portátil) para que estén en la misma subred? Si haces un ping desde tu ordenador a la IP del router, ¿éste te responde?

      Recuerda que en tu ordenador tienes que poner una IP del tipo 192.168.1.X, donde esa X es un número que va desde el 2 hasta el 254.

      También puede ocurrir que el router no esté en modo a prueba de fallos y por eso no tengas conexión a través de telnet.

  7. Hola. Quisiera saber como puedo resucitar el router tp-link tl-wr841nd V8.2 el cual no reconoce la ip por una falla de firmware de dd-wrt y solo enciende la luz de power. He efectuado un reseteo 30/30/30 y 90/90/90 y sigue igual, al reiniciarlo encienden todas las luces que luego se apagan y solo queda la de power, asi no puedo ponerlo en modo prueba de fallos para acceder con telnet. Si alguien sabe como se puede recuperar le agradeceria me lo dijera, antes de tirar el aparato a la basura. Gracias

    • Hola, José Luis,

      Si has probado todo lo que se comenta en el artículo, sólo te queda mancharte las manos: abrir el router y comunicarte con él a través de una conexión serie directamente hacia la placa. Necesitarás:

      • Cable serie TTL (el cable de Nokia CA-42 puede servir).
      • Soldador.
      • Programa para establecer conexión serie:
        • PuTTY (Windows).
        • minicom (GNU/Linux).

      Tienes información en la wiki oficial sobre cómo establecer la conexión serie a nivel de hardware y luego este post del foro con todo el procedimiento.

      Debo advertirte que nunca he probado este método y que deberías leer perfectamente toda la documentación que te encuentres al respecto (fijándote en la versión del router) para no dañar completamente el router y, como bien dices, tener que tirarlo a la basura.

      Siento no poder ayudarte más desde la experiencia, aunque ten por seguro que, si algún día me ocurre un desastre similar y logro solucionarlo, pondré aquí todos los pasos.

      ¡Suerte! ;-)

      PD Acabo de encontrar un vídeo que seguramente te ilustre muchísimo más toda la operación.

  8. Gracias por la información, pero creo que aqui acaba todo, para la electronica y soldadura soy un cero a la izquierda y no me veo capaz de hacer lo que dice en el video, de todas formas si consiguiera hacerlo ya os lo día. Gracias de nuevo

    • No te desanimes, José Luis. Si ya no tienes nada que perder, es una buena ocasión para lanzarte y experimentar. Seguro que conoces a alguien que sepa soldar, aunque sea lo más básico. Yo también soy un negado para la electrónica, pero si ya tengo un pisapapeles, me arriesgaría. Siempre aprendemos algo más :-)

      ¡Ánimo!

  9. Que desastre!!
    Me pasa lo mismo que a Jose Luís, a las 2 horas de comprar el router ya me lo había cargado.
    No se si abrirlo o lanzarlo por la ventana.

    • Hola, Sheila,

      Vaya lata que está dando este pobre router :-( Me gustaría saber qué fue lo último que estabas haciendo antes de que dejara de funcionar. A ver si logramos devolverlo a la vida ;-)

  10. Pues actualicé el firmware del router con el dd-wrt.
    No hubo incidencias, actualizó bien, se reinició y Fin.
    Sólo tiene encendido el led de power.
    Ni el 30-30-30, ni el reset, ni na de na.
    Yo tengo fe en que, algo se le podrá hacer.
    Y es que, no aprendo, ya con el movil tuve un buen susto tambien, puesto que le cambié la Rom, y luego iba de pena, menos mal que pude volver a poner la de Samsung. Que le voy a hacer. :-)

    • Bueno, ahora conozco mejor tu problema, Sheila. Has instalado el firmware DD-WRT y en este artículo se habla sobre otro, el OpenWrt. Nunca he tenido que vérmelas (por ahora) con problemas con ese firmware, pero recuerdo bien el reset 30/30/30.

      ¿Has probado a establecer conexión con el router? Me refiero a conectar otro equipo a él mediante un cable de red. Tu equipo lo configuras con una IP estática del tipo 192.168.1.X y compruebas si te responde el router, que con ese firmware tendrá la dirección por defecto 192.168.1.1. Quizás el router sí esté vivo. Resumiendo, desde un equipo haces:

      ping 192.168.1.1

      A ver si tenemos noticias del enfermo.

      PD Sobre cambios de ROMs y problemas con el teléfono puede hablarte bastante Ester, que hace de mi conejillo de indias :-P

  11. Pues nada, ni con telnet, ni poniendo una ip etática, ni na de na.
    Mi router no responde.
    Muchas gracias por tu ayuda. Una cosita más:
    Sé que hay muchas páginas y demás para flashear con openwrt, pero me puedes indicar un tuto de plena confianza para flashear un wr841nd v8.2?, por si lo vuelvo a intentar (que seguro que si). :-)

    • Lo siento mucho, Sheila. Pero no te desanimes, que siempre está la opción hardcore de abrir, cablear, soldar, etc. Es la que mete más miedo, pero a la vista de sus resultados es la mejor alternativa.

      En cuanto a flashear con OpenWrt, es muy sencillo si tienes acceso al panel de administración web del router. En ese caso (con el firmware de fábrica, el de TP-Link), basta seguir las instrucciones de la Wiki oficial. En su día yo lo hice de esa manera y no tuve ningún problema. También tengo la versión 8.2 ;-)

      Estamos aquí para echar una mano y aprender entre todos ;-)

      ¡Mucha suerte y nunca dejes de cacharrear!

  12. Gracias por las indicaciones, he llegado hasta aqui precisamente porque quiero usarlo como repetidor de wifi… Vaya que extraño los Ubiquiti Unifi de mi empresa cuando estoy en casa.

    A todo caso, he realizado todo hasta la parte de reinicio (reboot -f), sin embargo al parecer nunca termina de reiniciar, se queda colgado el comando, sin ninguna señal de exito o error y despues no puedo entrar ni por ssh ni por telnet… me toca volver a empezar desde cero..

    Alguna idea?

    Gracias

    • Me Respondo, despues de ejecutado el reinicio hay que cambiarse a uno de los puertos lan, al menos en el modelo v8, puesto que por defecto no tiene acceso desde el puerto WAN.

      Gracias

      • ¡Muy buenas, Liko28s!

        Perdona por tardar en responderte. Me alegra que hayas encontrado la respuesta. Sí, lo del puerto WAN también me dio dolores de cabeza a mí. Son de esas cosas que acabas probando un poco por desesperación y, cuando ves que funciona, te quedas con cara de «¿en serio era por esto?», jejeje. Quizás no dejé claro en el artículo que ese puerto sólo lo usamos para el modo a prueba de fallos de OpenWRT.

        Un saludo y, ahora sí, a disfrutar del router ;-)

  13. Hola JM

    Estoy intentando revivir el mio después de intentar cargar un sysupgrade y se ha quedado medio frito. El caso es que consigo entrar en el modo safe como lo indicas pero al ejecutar los comandos me aparece lo siguiente:

    root@(none):/# mount_root
    Unlocking rootfs …
    oot@(none):/# passwd
    Changing password for root
    New password:
    Retype password:
    passwd: can’t create ‘/etc/shadow+’: No space left on device
    passwd: can’t update password file /etc/shadow
    root@(none):/# firstboot
    firstboot has already been run
    jffs2 partition is mounted, only resetting files
    MTD partition not found.

    Y me temo que ya no hay forma de recuperarlo. ¿Estoy haciendo algo mal? Gracias!

    • Muy buenas, Juan,

      Para descartar que sea otro tipo de problema, comprueba si realmente hay o no espacio en el dispositivo:

      Usa el comando df -h dentro de la sesión como root (lo mismo que has hecho arriba) y pégalo por aquí.

      A ver si logramos recuperar al paciente ;-)

  14. Hola JM, disculpa el retraso en contestarte y gracias por el interés

    Lo que me arroja el df -h es

    Filesystem Size Used Available Use% Mounted on
    rootfs 2.9M 2.9M 0 100% /
    /dev/root 2.9M 2.9M 0 100% /
    tmpfs 14.3M 16.0K 14.3M 0% /tmp
    tmpfs 512.0K 0 512.0K 0% /dev

    es decir entiendo que está “full”. Hay alguna forma de “formatearlo”? El problema es que instalé un firmware jffs en este modelo cuando (más tarde) encontré que por el tamaño no había que hacerlo porque podía “brickear” el router … como así ha sido.

    Espero que no tenga que utilizar el puerto serie (porque me resulta complicado) y haya alguna forma más “soft” de solucionarlo. Gracias

    • Muy buenas, Juan,

      Perdóname ahora a mí por tardar en contestarte. No he podido investigar como debería el asunto, pero vamos a ir haciendo comprobaciones. Veamos si te deja ejecutar comandos simples como el ls (para listar los archivos que hay en un directorio). Haz la prueba y me comentas a ver si encuentras alguno llamado firmware.

      También prueba a lanzar el siguiente comando: mtr, sin más opciones, sólo para saber si lo tienes instalado y te funciona.

  15. Colega eres un fenómeno, el tutorial está de puta madre, fácil y bien explicado. Aparte decir que en la V9 funciona perfecto. Muchas gracias.

    • ¡Buenas, rober!

      Caray, con tu comentario no logras más que darme alas y querer seguir investigando y compartiendo todo lo que aprenda con vostros ;-)

      ¡Muchas gracias!

      PD Gracias también por confirmar que funciona en la v9 de este router.

  16. Hola JM,

    Garcias por tus comentarios.

    El ls funciona, pero no hay ningún archivo firmare. He encontrado varios directorios firmare en lib, sys vacíos y en sys/class hay otro con un solo archivo “time out”

    Por otra, mtr no esta instalado

    Gracias¡

  17. Hola JM

    El “ls” funciona pero no hay archivos “firmware” sólo tres directorios: sys, lib, sys/classes y dentro vacíos

    “mtr” no esta instalado.

    Gracias!

  18. Hola JM

    Asunto resuelto, después de mucho batallar he conseguido arreglarlo.

    He utilizado http://wiki.openwrt.org/doc/howto/generic.sysupgrade (Sysupgrade) transfierendo el .bin con ‘nc’ desde una máquina ubuntu (desde la mía MacOsx tenía problemas de conexiones rechazadas…) y cargándolo con sysupgrade.

    Parece que tenía que tomarme unas vacaciones para resolverlo y ahora que las tengo … voilà! resuelto

    gracias en cualquier caso por el apoyo

    Feliz Navidad!

    • Que tal Juan ahora mi toca a mi revivir mi ladrillo v 8.0, y mencionas que tu realizaste un Sysupgrade, voy a ayudarme con traductor de google, pero mi duda inicial, este método es por el puesto COM o mediante el cable de red?

      Te agradecería mucho mano

      adiosalfc@gmail.com

  19. ¡Muy buenas, Juan A!

    Últimamente no tengo tiempo para cacharrear y parece que te dejé abandonado. Pero me alegra un montón que lo hayas conseguido por tu cuenta, veo que eres de lo que no se rinden fácilmente ;-)

    El método del netcat sería de las últimas opciones a probar porque no suele ser recomendable, pero con valientes como tú nada se resiste.

    Muchísimas gracias a ti por compartir tu solución, que seguro ayudará a quienes se enfrenten al mismo problema.

    Han sido mano de santo esas vacaciones ;-)

    ¡Felices fiestas!

  20. Que ta compañeros, el problema que tengo es que mi router al intentar actualizar el firmeware se fue la luz y no se completo la actualizacion, Es posible utilizar el método anteriormente descrito? Que OS utilizan? yo lo intente hacer la actualizacion desde windows. Ua instale TELNET pero no se que mas hacer agradezco cualquier ayuda que puedan brindarme

    • Eduar, ¿qué firmware intentabas actualizar? Este artículo está centrado en el firmware OpenWrt, no vale para otros.

  21. Hola amigo, despues de leer tu post sobre este tema, quiero felicitarte y darte as gracias porque he podido revivir mi router Tp-link TL WR741nd. Estaba a punto de tirarlo a la basura. Muchas gracias. Solo me confundió que cuando das el ejemplo del IP colocas el simbolo $ y a continuacion el IP de ejemplo. Mirando otros tutoriales termine entendiendo tu post. Excelente trabajo amigo. Sigue Adelante. Saludos

    • Hola, Fernando,

      Me alegra saber que has revivido tu pequeñín.

      Tienes razón en que puede confundir lo de poner los símbolos $ o #. Sin embargo, lo hago para que se vea que unos comandos hay que ejecutarlos desde un terminal como usuario normal ($) y otros como administrador/superusuario/root (#).

      Gracias por tomarte la molestia de comentar ;-)

    • buenas tardes amigo como pudiste revivir el router 741nd yo estaba actualizando y se fue la luz y ahora el router solo enciende la luz de power le he dado los reinicios 303030 y nada he tratado de hacerlo por puerto ttl seria pero no he podido si me puedes orientar te lo agradezco gracias

      • Hola, Jose, ¿qué problemas te daba al intentar la conexión serie? ¿Qué cable y chipset has utilizado? ¿Cuáles fueron los pasos que diste?

  22. Buenas, tengo un WR841ND v8 y estuve en dd-wrt y no me reconocía el puerto WAN (No se si antes tampoco me lo reconocía) me volvi a tp-link con un firmware q encontré por internet, el cual lo flashee directamente desde la web y me anduvo. Y luego lo actualice con el original de la pagina de tp-link. Ahora, el modem me prende la luz al conectarlo al puerto wan de router pero en la configuración del router no me da la ip wan….
    pd: Llame a mi operadora y me dijeron que el modem prende la luz como que detecta “algo” pero no reconoce una placa de red ni nada.
    Mi pregunta es: Es un tema de hardware o de software?? Y si hay alguna forma de comprobarlo. Muchas gracias y un abrazo grande…
    Este es mi mail por si a alguien se le ocurre algo…
    gasparrg@outlook.com

  23. Hola, Gaspar,

    Quiero entender que tienes el WR841ND conectado al puerto WAN del router de tu compañía. De ser así, ¿el router primario (el de la compañía que te suministra internet) está en modo bridge (neutro)?

  24. Tengo un TP-link Modelo TL-WR841N, me lo configuraron , pero perdi la contraseñA. Como hago para reestablecerla . O que hago para reconfigurarlo.

    Saludos Gracias

  25. Soy de Panamá , mi contraseña la perdi y no se como rescatarla. es un TP-LINK, modelo TL-WR841N.

    SALUDOS

    • Hola, Oscar,

      Si no sabes la contraseña para acceder al router, puedes hacerle un reinicio de fábrica. Con el router encendido, pulsa el botón reset (en el lado opuesto al de encendido) durante al menos 5 segundos. Verás que se reinicia. Cuando vuelva a estar operativo, tendrá los ajustes por defecto, es decir, la configuración que traía de fábrica. Podrás, entonces, acceder a la administración a través de la dirección IP 192.168.0.1. Usuario y contraseña: admin. A partir de ahí, edita las opciones a tu gusto.

  26. hola antes q todo saludarlos tengo un TL-WR841N que se le a dañado el firmware pero me hace las siguientes cosas la lan ni la wan me funcionan sino q el router cae en un ciclo de reinicio es decir enciende el boton de power y el antepenultimo quisiera solucionar este problema cualquier solucion por favor escribrme a este correo juancarloslobaina@nauta.cu por favor les agradesere la ayuda el router no funciona no emite señal wifi ni deja entrar a la pagina de administracion por favor cualquir respuesta escribirme al correo q les deje anterior mente lo nececitooooooo¡¡¡¡¡¡¡

    • Hola, yulian,

      ¿Qué firmware tiene ese router? La mayoría permiten hacen un reinicio para devolverlo a su estado de fábrica, ¿lo has probado?

  27. hola tengo un router y lo flashee con openwrt preconfigurado pero ahora me redireccion a una pagina web rara cuando me quiero conectar.

    quiero resetearlo pero sin perder la informacion que tiene dentro es decir solo resetear la contraseña. es posible?

    • Hola, David,

      ¿Podrías ser más concreto en lo de me redireccion a una pagina web rara? ¿Cómo te conectas al router, por cable o por Wi-Fi?

      Si no recuerdas la contraseña para acceder a la administración del router, me temo que no tienes más opción que restaurar el firmware, perdiendo con ello todas las configuraciones.

  28. Tengo un router TP-LINK TL- WR741ND al cual le coloqué la dd-wrt correspondiente, y si bien me daba la ip con un ipconfig, no me permitía entrar a la configuración. Lo borré entrando por telnet con el comando “mtd erase linux” y ahora tengo todas las luces titilando.
    Hay alguna forma de instalarle el bin original o el OPENWRT por Telnet y a través del RJ45 o con alguna aplicación específica ?
    Gracias de antemano
    Jose Luis Castro

    • Hola, Jose Luis,

      Voy a suponer que el router ha quedado en un estado inservible. Depende de la versión del hardware (puedes saberlo echando un vistazo a la pegatina que hay en la base del router), sería posible cargar un firmware de recuperación mediante TFTP, como indica la wiki de OpenWrt.

      Si te queda alguna duda, aquí estamos ;-)

      ¡Suerte!

  29. MAN SOLO PUEDO DECIRTE QUE ERES MI HÉROE DE PANA ESTE RAUTER LO COMPRE NUEVO PARA USARLO DE REPETIDOS Y LUEGO SOLO LOGRE USAR DE PISA PAPELES COMO SE ME DAÑO EL PRINCIPAL QUERIA VER SI PODIA REVIVIR ESTE Y JUSTO DI CON TU POST LO QUE NO SE ES POR QUE NUNCA PENSÉ EN EL TELNET UN MILLÓN DE GRACIAS

  30. amigo por casualidad no tienes idea de que pueda hacer para revivir mi 741nd v4 lo actualize con el firnware mas reciente de la pag de tp-link y el router murio… solo queda el led de power encendido, no enciende las otras leds y ni en modo a prueba de fallos puedo entrar.

  31. Hola:

    Mi problema es el siguiente: instalé openwrt, algo salió mal. No puedo acceder a ninguna interfaz del router. Cuando hago el procedimiento que arriba explicas: se pone a conectar con el router pero al final aparece el mensaje “could not connection to the host, port 23…” y nada, que no es posible acceder al puñetero router ¿ Qué me recomiendas? Es una versión 11.1

    Saludos

    • Hola, Iván,

      Echando un vistazo a la wiki oficial, la versión 11.x no está soportada oficialmente, al menos por ahora. Sin embargo, en los foros, ciertos usuarios comentan que han sido capaces de instalarlo (tienes allí el firmware modificado). Si crees que el cacharro te ha quedado inservible, es más que probable que necesites emplear el método por TFTP para recuperarlo.

      ¡Suerte!

  32. hola yo se que este post es viejo tengo un router wdr3600 con openwrt de golpe no me anda , prende y todo no lo puedo revivir por red alguna forma de hacer un cable de usb a serie porque vi que en la placa tiene conectores como hago esos cables

    y me gustaria volver al firmware original

  33. Hola estimados. Saludos.

    Tengo lo siguiente, es un router TPlink modelo TL-WR841N, la cuestion es que lo tenia guardado y ahorita q me dio por volverlo a la vida veo que el equipo mantiene titlando el Led de la rueda dentada. Ya hice reset de fabrica, tanto a nivel fisico (tecla reset) como a nivel logico (pag admin) y nada que se le quita. Lo tengo conectado al modem pero no me deja salir a internet. Tendran alguna pista q me puedan dar sobre porque sucede esto? Quedo atento a sus comentarios y desde ya, gracias.

    Saludos

    • Hola, Marcelo,

      Siento haber tardado tanto tiempo en contestarte y no sé si leerás esto. ¿Qué firmware tiene instalado tu router? Si tiene OpenWrt, quizás esté activado el modo a prueba de fallos. En ese caso, podrías seguir las indicaciones de este artículo y lograr reinstalar el firmware.

  34. Solo tengo dos palabras para ti: muchisimas gracias.
    Casi lloro al pensar que mi router habia mierto pero encontre tu post y me salvo la vida. En serio gracias.

    • Vaya, Miki, da gusto leer comentarios como el tuyo :-D

      Muchísimas gracias a ti por sacarme los colores, jejeje. Disfruta de la nueva vida de tu router ;-)

  35. Hola…tengo un problema con un router tp link tl-wr700n ke actualizando el software se me murio…existiria alguna manera de revivirlo.???..Por favor..!!..necesito ayuda.!!..Gracias

    • Hola, Alessandro,

      ¿Tu router tiene OpenWrt o el firmware original? Cuando dices que estabas actualizando el software, ¿te refieres al firmware?

  36. dejo esto por aca quizas es util para cuando falle por memoria saturada y no te deje guarda la contraseña por falta de espacio …. entrar por telnet y tus comando no andaban ya que tenia la memoria saturada (la memoria de las particiones), use en modo de fallos “telnet 192.168.1.1″ luego ” cd /tmp” luego ” wget (rura del servidor)/(nombre del archivo.bin” (wget ftp://192.168.1.104:2221/v7stable.bin ) y luego a disfrutar mi configuracion fue el router con openwrt en modo de fallos luego, conectado a mi router principal por lan, luego una aplicacion de mi smartphone que realiza la funcion ftpserver conectado por wifi a mi router principal , y ejecutar todos los comandos con mi pc por wifi utilizando cmd de windous telnet o putty mediante telnet si alguien necesita ayuda algun dia buscame en https://www.facebook.com/agustin.avellaneda1 o bien xfx6200@gmail.com . Saludos!

  37. Hola amigo recien me compre un router TL-WR941ND al principio con su firmware original trabajaba bien lo malo es que estaba en idioma portugues asi que decidi actualizarlo al ingles, luego buscando en internet me encuentro con que puedo actualizarlo a openwrt buscando encontre el firmware pero sin interfas web, ahi se complico todo luego que hice el update a openwrt se que tenia que entrar por telnet a la direccion 192.168.1.1 para poder cambiarle el password, pero nunca lo logre ni por putty, la cuestio es que ahora no enciende ningun led dolo el de power, lo desarme y trate de hacer el procedimiento ttl y sin exito dime que puedo hacer para poder repararlo,, consta decir que vivo en cuba y un router como ese cuesta 100 cuc jeje please ayuda…

    • Hola, Luis Angel,

      El último recurso es conectarse al router por el puerto serie. Comentas que ya lo has intentado, ¿me podrías decir qué has hecho exactamente?

  38. porque mi router TP-Link WR841N se queda con todas las luses amarillas encendidas cuando lo enciendes sin parpadear ninguna

  39. mi TP-Link TL-WR841ND se queda con todas las luses prendida sin pestañar como puedo arreglarlo necesito ayuda porfavor

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *